Degraded Performance with Virtuous Payments

Minor incident Donation Page Donor Portal
2022-10-03 12:53 PDT · 40 minutes

Updates

Resolved

A fix has been deployed and response times and error rates have returned to normal levels. We will continue to monitor the situation.

October 3, 2022 · 13:33 PDT
Issue

We are aware of an incident involving higher than expected API response times and error rates from our upstream processor. We are monitoring the status with the processor closely.

October 3, 2022 · 13:11 PDT

← Back