ACH Tokenization Errors with Virtuous Payments

Minor incident Donation Page Donor Portal
2022-10-04 06:44 PDT · 3 hours, 4 minutes

Updates

Resolved

Issue is fully resolved.

October 4, 2022 · 09:48 PDT
Monitoring

A fix has been deployed. We are monitoring to confirm the issue is resolved.

October 4, 2022 · 09:08 PDT
Issue

We have been notified of an increase in ACH tokenization errors with our upstream processor affecting the ability to add or update an ACH payment method with Virtuous Payments. We are monitoring for updates.

October 4, 2022 · 08:15 PDT

← Back