Virtuous Payments Processing Issues

Minor incident Donation Page Donor Portal
2022-11-18 09:15 PST · 30 minutes

Updates

Post-mortem

Issue is fully resolved after an update was rolled back.

November 18, 2022 · 10:29 PST
Update

We have identified the issue related to a recent update. We have rolled back the update and we are monitoring for any further issues.

November 18, 2022 · 10:10 PST
Monitoring

Virtuous Payments is experiencing issues processing donations. We are investigating.

November 18, 2022 · 10:04 PST

← Back