Temporary Issue with One-Time Donations via RaiseDonors + Virtuous Payments

Major incident Donation Page
2023-04-11 10:25 PST · 3 hours, 31 minutes

Updates

Resolved

The issue with one-time donations through RaiseDonors + Virtuous Payments has been resolved. Our payment processor, STAX, has implemented the necessary fix, and all donation functionalities are now operating as expected. We appreciate your patience during this time and apologize for any inconvenience this may have caused.

April 11, 2023 · 13:56 PST
Issue

We are currently experiencing issues with one-time donations through RaiseDonors + Virtuous Payments. The issue has been identified as a change made to the client-side JS library by the payment processor STAX, which requires a fix on their end. We have reached out to STAX and will provide updates as we receive further information from their team.

April 11, 2023 · 12:51 PST

← Back