Intermittent transaction issues with Virtuous Payments

Minor incident Donation Page Donor Portal
2023-06-12 14:23 PDT · 16 hours, 54 minutes

Updates

Resolved

We have been notified by our payment processor Stax that this issue has been resolved.

June 13, 2023 · 07:15 PDT
Issue

We’re currently aware of intermittent transaction issues with Virtuous Payments. Our payment processor, Stax, is actively investigating these occurrences. We are closely monitoring the situation and will provide further updates as soon as they become available.

June 12, 2023 · 14:23 PDT

← Back