RaiseDonors SSL Error

Major incident Admin Dashboard Donation Page API Donor Portal Integrations
2024-01-25 06:58 PDT · 18 minutes

Updates

Resolved

We have resolved the error. All services should be back to normal. Thank you for your patience.

January 25, 2024 · 07:13 PDT
Issue

We are investigating an SSL certification error with our cloud provider Azure. We are working to resolve the issue immediately. Apologies for the disruption.

January 25, 2024 · 06:58 PDT

← Back