Issues Processing Payments with Virtuous Payments with Stax

Major incident Donation Page
2024-03-27 13:50 PDT · 27 minutes

Updates

Resolved

We’ve identified a validation issue in our system that was included in a recent release. We’ve rolled back the change and are seeing processing issues are resolved. If you are still encountering an issue please reach out to support to notify us.

March 27, 2024 · 14:15 PDT
Issue

We are investigating issues processing payments with Virtuous Payments powered by Stax.

March 27, 2024 · 13:50 PDT

← Back