Intermitent Loading Issues

Major incident Admin Dashboard Donation Page Donor Portal
2025-02-24 09:02 PST · 1 hour, 8 minutes

Updates

Resolved

Our team has resolved the DNS issues that were causing page loads in RaiseDonors.

February 24, 2025 · 10:09 PST
Investigating

We have determined this issue to be related to DNS. We are working with our provider on a solution.

February 24, 2025 · 09:26 PST
Issue

We are aware of an issue that is causing intermittent issues loading RaiseDonors pages within the application and hosted pages or forms. Our engineering team is actively investigating this issue.

February 24, 2025 · 09:02 PST

← Back