Donor Portal Access
Major incident
Donor Portal
2025-11-10 11:15 PST
· 2 days, 4 hours, 1 minute
Updates
Monitoring
November 12, 2025 · 11:45 PST
Our engineering team identified an issue impacting the RaiseDonors Donor Portal, which prevented some donors from logging in, resetting their passwords, or updating and saving payment methods. A fix has been deployed, and we are actively monitoring.
Investigating
November 11, 2025 · 11:15 PST
We are aware of an issue impacting the RaiseDonors Donor Portal and password reset functionality, which is preventing some users from accessing their accounts. Our engineering team is actively investigating the root cause and working to restore full functionality as soon as possible.
← Back