Processing Delays

Minor incident Admin Dashboard
2025-12-19 07:20 PST · 5 hours, 13 minutes

Updates

Resolved

The issue affecting Virtuous Raise function apps has been fixed. The system will now self-recover, and all queued emails, exports, and related processing will be sent out shortly.

We are monitoring closely as the backlog clears and will provide a final update once processing has fully returned to normal.

December 19, 2025 · 12:33 PST
Issue

We are currently investigating an issue affecting Virtuous Raise related to function apps. This issue is causing delays in email sending, downloads becoming stuck, and delays in gift syncing to the CRM.

Our engineering team is actively working to identify the cause and restore normal processing. Updates will be provided as more information becomes available.

December 19, 2025 · 07:20 PST

← Back